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NOTICE: This document is under development

1. Introduction

Quantum GIS (QGIS) is designed to be a Geographic Information System (GIS) built for
Linux/Unix. QGIS currently offers basic support for vector, raster, and database formats.

Note:
The latest version of this document can always be found at http://qgis.sourceforge.net/docs/userguide.html

2. Current Features

• Support for spatially enabled PostgreSQL tables using PostGIS
• Support for ESRI shapefiles and other vector formats support by the OGR library
• Identify features
• Display attribute table
• Select features
• Persistent selections
• Save projects
• Support for raster formats supported by the GDAL library
• Change vector symbology (single, graduated, and continuous)
• Display raster data such as digital elevation models, aerial photography or landsat

imagery
• Change raster symbology (grayscale, pseudocolor and multiband RGB)
• Export to Mapserver map file

3. Getting Started

This section gives you a quick overview of running QGIS and examining data available on
the QGIS web page.
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3.1. Installation

Installation of QGIS is documented in the Installation Guide.

3.2. Sample Data

If you do not have any GIS data, you can obtain a dataset for Alaska (which will be used as
the basis for the examples and screenshots provided in this document) from the the QGIS
web site

3.3. Starting QGIS

Assuming the QGIS is installed in the PATH, you can start QGIS by typing: qgis.

In addition, you can start QGIS by specifying one or more datafiles on the commandline. For
example, assuming you are in your data directory, you could start QGIS with two shapefiles
and a raster file set to load on startup:

qgis ak_shade.tif alaska.shp majrivers.shp
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QGIS Load Data On Start

Note:
Your window decorations (title bar, etc.) may appear different depending on your operating system and window manager

3.4. The QGIS main window

When QGIS starts, an empty window is displayed as shown below.
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QGIS Main Window

The QGIS main window is divided into five areas:

1. The menu bar
2. The tool bar
3. The map legend
4. The map view
5. The status bar

These five parts of the main QGIS are described in more detail in the following sections

3.4.1. The QGIS menu bar

The menu bar provides access to various QGIS features using a standard windows
heirachical menu.

The File Menu:

•
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Open Project
- Open a previously saved project.

•

Save Project
- Save the current project.

•

Save Project As
- Save project under a new file name.

•

Export to mapserver
- Export your current project as a mapserver map file. Note that not all mapserver
features are available in the exported mapfile.

•

Exit
- Exit the QGIS application.

The View Menu:

•

Add Postgis Layer(s)
- Add one or more layers stored in a PostgreSQL/Postgis geodatabase to the map view.

•

Add Vector Layer(s)
- Add one or more layers stored on disk as shapefiles to the map view.

•

Add Raster Layers
- Add one or more raster layers to the map view.

The Tools Menu:

•

Plugin Manager
- This opens a dialog that allows you to manage (load and unload) which plugins are used
in QGIS.

•
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Check Version
- This option connects over the internet to the QGIS server to find out what the latest
available version is. No personal data is sent to the QGIS server.

•

Preferences
- Global configuration options for the QGIS application.

The Help Menu:

•

Contents
- This opens the help documentation you are reading right now!.

•

QGIS Home
- Clicking this menu option will take you to the QGIS internet home page using your
preferred browser.

•

SourceForge Home
- This will take you to the Sourceforge.net project page for QGIS.

•

About
- Click here to find out some useful information about the current version of QGIS you
are using. If you want to frighten yourself silly, take a look at the Contributors tab to see
all the hardworking elves behind the QGIS effort.

3.4.2. The QGIS toolbars

QGIS has toolbars that provide quick access to commonly used functions. These are:

•

New Project
- Start a new QGIS project. If you already have a project ope, you will be asked if you
would like to save the existing one first.

•

Open Project
- Open a previously saved project.

•

Save Project
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- Save the current project.
•

Save Project As
- Save project under a new file name.

•

Add Postgis Layer(s)
- Add one or more layers stored in a PostgreSQL/Postgis geodatabase to the map view.

•

Add Vector Layer(s)
- Add one or more layers stored on disk as shapefiles to the map view.

•

Add Raster Layers
- Add one or more raster layers to the map view.

•

Reload
- Reload the current map view (refreshes display)

•

Zoom In
- Zoom in the map display by dragging a rectangle

•

Zoom Out
- Zoom out of the map display by dragging a rectangle. Dragging a small rectangle will
zoom out a long way, dragging a large rectangle will zoom out a little way.

•

Zoom Full Extent
- Zoom out until all features in all map layers are visible.

•

Zoom to Selected
- Zoom to fit all selected features in the map view.

•

Pan
- Pan in the map display area.
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•

Zoom to Previous
- Zoom to last extents.

•

Identify
- Show information about a feature (applies only to vector data).

•

Select Features
- Select features in the map display (applies only to vector data).

•

Show Attributes
- Show the attribute table for the selected layer (applies only to vector data).

3.4.3. The QGIS map legend

The map legend area is used to set the visibility and z-ordering of layers. Z-ordering means
that layers listed nearer the top of the legend are drawn over layers listed lower down in the
legend. The checkbox in each legend entry can be useed to show/hire that layer.

3.4.4. The QGIS map view

This is the 'business end' of QGIS - maps are displayed in this area! The map displayed in
this window will depend on the vector and raster layers you have chosen to load (see sections
that follow for more info on this). The map view can be panned (shifting to focus of the map
display to another region), zoomed in and out, and supports various other actions as
described in the toolbar description above.

The map view and the legend are tightly bound to each other - the maps in view reflect
changes you make in the legend area.

3.4.5. The QGIS map status bar

The status bar shows you your current position in map coordinate (e.g. meters or decimal
degress) as the mouse pointer is moved accross the map view.

4. Working with vector data

4.1. Loading vector data
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To load one or more shapefiles, click on the Add Layer button

Add Layer
.

The Select one or more layers to add dialog box will be displayed.

Select layers

Navigate to the directory where the shapefiles reside. Select one or more files and click ok to
load them.

When QGIS loads a layer, it assigns a random color to it as shown below.
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Shapefiles loaded into QGIS

Obviously QGIS's choice of colors is not very pleasing in this case.

4.2. Changing Symbology

To make the layer more appealing, open the Layer Properties dialog by right-clicking on a
layer name in the table of contents (left side of the QGIS window) and selecting Properties.

If you like, change the display name of the layer by editing the Display name field.
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Layer Properties

Click on the Legend tab to display the current symbols used for the layer
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Display name

Click on the Outline color and Fill color and select a new color from the color chooser. You
can also change the line width if desired.
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Changing colors

After making the changes, click Ok to apply the changes to the layer. Note that the alaska
layer has been renamed to Alaska and the color has been changed to a light green:
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Changing colors

4.3. Identifying a Feature

QGIS provides a useful tool (

Identify
- the 'identify' tool) that allows you to click on a vector feature ( point, line or polygon) and
view information about that feautre. The information displayed is retrieved from the Postgres
database (in the case of Postgis layers) or from the .dbf file associated with the shapefile you
are insecting.

5. Working with raster data

5.1. What is raster data?
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Raster data in GIS are matrices of discrete cells that represent features on, above or below the
earth's surface. Each cell in the raster grid is the same size, and cells are usually rectangular
(in QGIS they will always be rectangular. Typical raster datasets include 'remote sensing'
data (such as aerial photography and satellite imagery) and modelled data (such as an
elevation matrix).

Raster data typically do not have an associated database record for each cell (unlike in vector
data where it is normal for each feature to have an associated database record).

In GIS, a raster layer would have geopositioning data associated with it which will allow it to
be positioned correctly in the map display to allow other vector and raster data to be
overlayed with it. QGIS, can read this geopositioning data to facilitate properly displaying
map overlays.

5.2. Raster formats supported in QGIS.

QGIS supports a number of different raster formats. Currently tested formats include:

• Arc/Info Binary Grid
• Arc/Info ASCII Grid
• Grass Raster
• GeoTIFF
• Spatial Data Transfer Standard Grids (with some limitations)
• USGS ASCII DEM
• Erdas Imagine

Because the raster implmentation in QGIS is based on the GDAL abstraction library, orther
raster formats implemented in GDAL are also likely to work, but have not yet been tested.
See the GDAL Raster Formats page for more details.

5.3. Loading raster data in QGIS

Raster layers are loaded either by clicking on the

Load Raster
icon or by selecting the View->Add Raster Layer menu option. More than one layer can be
loaded at the same time by holding down the Control key and clicking on multiple items in
the file dialog.

5.4. Symbolisation and properties for raster layers
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Symbolisation of raster layers is achieved by right clicking on a raster layer legend entry and
choosing 'properties': on the popup menu that appears:

Raster Properties Popup

On the properties dialog for rasters you will see there are three tabs:

5.4.1. The general properties tab

Raster Properties Popup
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The legend tab displays basic information aboug the selected raster - including its dimensions
(in pixels) and its display name in the legend.

5.4.2. The symbology properties tab

Raster Properties Popup

QGIS supports three forms of raster layer:

• Single Band Grayscale Rasters
• Palette Based RGB Rasters
• Multiband RGB Rasters

From these three basic layer types, eight forms of symbolised raster display can be used:

1. Single Band Grayscale
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2. Single Band Pseudocolor
3. Paletted Grayscale (where only the red, green or blue component of the image is

displayed)
4. Paletted Pseudocolor (where only the red, green or blue component of the image is

displayed, but using a pseudocolor algorithm)
5. Paletted RGB
6. Multiband Grayscale (using only one of the bands to display the image)
7. Mulitiband Pseudocolor (using only one of the bands shown in pseudocolor)
8. Multiband RGB (using any combination of three bands)

QGIS has the capability to invert the colours in a given layer so that light colors become dark
(and dark colors become light). Use the 'Invert Color Map' checkbox to enable / disable this
behaviour.

QGIS has the capability to display each raster layer at varying transparency levels. Use the
transparency slider to indicate to what extent the underlying layers (if any) should be visible
though the current raster layer.

QGIS has the capability to restrict the data displayed to show only cells whose values are
within a given number of standard diviations of the mean for the layer. This is useful when
you have one or two cells with abnormally high values in a raster grid that are having a
negative impact on the rendering of the raster. This option is only available for pseudocolor
images.

5.4.3. The raster statistics properties tab
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Raster Properties Popup

This tab displays statistics about each band in the current raster layer. Statistics are gathered
on a 'need to know' basis, so it may well be that a given layer's statistics have not yet been
collected.

Statistics for a layer are gathered when pseudocolor rendering is selected and the 'apply'
button is pressed.

Note:
Gathering statistics for a layer can be time consuming. Please be patient while QGIS examines your data!

6. Creating a QGIS mime type

If you are a KDE user, you can create a mime type that associates GIS files with QGIS. This
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is useful because it allows you to click on a shapefile (for example) in konqueror and the file
will be loaded in a new instance of QGIS.
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